Using the ActiveState Platform you can import and manage your requirements for your Python, Perl, or Ruby project by importing the specific requirements files directly into your project. The Platform supports the following requirements file formats:
In order for the import to be successful, the format of the requirement file must be associated with the matching language. The Platform parses each entry in your requirements list, validates the syntax, and identifies any issues. When the file is valid, the Platform attempts to match each package requirement with a package and version available.
If you have an existing Python project that you want to add to the Platform, you can export a
requirements.txt file to get a list of packages and versions to import into your Platform project, or you can type in the list of packages and versions manually. The syntax of the file must meet the following criteria:
piprequirement specifier syntax shown in the table below:
|==||Equal to||An exact match is required.|
|>||Greater than||Use any version greater than the specified version.|
|>=||Greater than or equal to||Use any version greater than the specified version.|
|<||Less than||Use any version less than the specified version.|
|<=||Less than or equal to||Use any version less than or equal to the specified version.|
|~=||Compatible version||Use any version greater than or equal to the specified version, but not greater than the current release series.|
~=1.4.2 matches 1.4.2 through 1.4.9) but does not match 1.5.0
The following requirement specifier syntax is not applicable to the ActiveState Platform and is not supported:
SomeProject ==5.4 ; python_version < '2.7') are not supported. Instead, you should specify the appropriate package requirement specifier for your Platform project’s Python version.
SomeProject @ file:///somewhere/...) are not supported because all requirements for a Platform project must come from the Platform.