| Store | Cart

ActiveState Docs

PDK 9.3 Documentation

Loading...

VBScript Converter - Graphical Interface

The VBScript Converter includes a graphical interface for converting VBScript to Perl. It allows users to:

  • easily compare the original VBScript or VBA code with the results of the conversion

  • open saved VBScript code snippets and programs in the Input pane

  • edit, copy, cut, and paste code in the Input and Output panes

  • save input or output code

  • set conversion options

Panes

The VBScript Converter graphical interface displays both an Input and Output pane by default. These windows can be resized by clicking and dragging the vertical divider. 'Ctrl'+'Click' toggles between single pane views, and 'Shift'+'Click' toggles view splitting (Note that these shortcuts are accessed by clicking on the toolbars in the the Input and Output panes).

Input

The Input pane displays VBScript code snippets and programs for conversion. Code can be pasted into this pane from the Windows clipboard or loaded from a file. The code is syntax-highlighted and can be edited and saved. The toolbar in the Input pane contains the following options:

Select Type Library
If necessary, use the drop-down list to specify the type library that the script will use.

Run Conversion
Converts the code currently displayed in the Input pane into equivalent Perl in the Output pane.

Cancel Conversion
Cancels a running conversion.

Clear Input
Clears the Input pane.

Open Input
Load input text from a file. If the Input pane already contains code, you are prompted to save it.

Close
Hides the Input pane.

These functions are also available from the drop-down menus. See the Drop-Down Menus for keyboard and mouse shortcuts.

Output

The Output pane displays Perl code produced by the VBScript Converter. This output can be copied and pasted into a Perl program displayed in an editor (e.g. Komodo or Emacs). The toolbar in the Output pane contains the following options:

Copy All
Copy the entire contents of the Output pane so that they can be pasted into a Perl script.

Save
Save the contents of the Output pane to a file.

Close
Hide the Output pane.

Drop-Down Menus

File menu

New Input ('Ctrl'+'N')
Clears the Input pane. Prompts to save changes, if the current contents of the Input pane are not saved.

Open Input ('Ctrl'+'O')
Load input text from a file.

Save Input ('Ctrl'+'S')
Saves the code in the Input pane. Prompts for a filename if the code is currently unsaved (e.g. pasted from the clipboard).

Save Input As
Saves the code in the Input pane. Prompts for a filename even if the contents are currently saved as a file.

Recent Files
Displays a list of recently accessed Input files.

Load Clipboard Contents
Pastes the contents of the Windows clipboard in the Input pane.

Save Output
Saves the output of the conversion. Prompts for a filename if the code is currently unsaved.

Save Output As
Saves the output of the conversion. Prompts for a filename even if the contents are currently saved as a file.

Exit
Closes the VBScript Converter.

Edit menu

Cut ('Ctrl'+'X')
Cuts the selected text, saving a copy in the Windows clipboard.

Copy ('Ctrl'+'C')
Copies the selected text to the Windows clipboard.

Paste ('Ctrl'+'V')
Pastes text from the Windows clipboard at the current cursor position.

Undo ('Ctrl'+'Z')
Undo the last change.

Redo ('Ctrl'+'Y')
Redo the last change.

Delete ('Del')
Delete the selected text.

Select All ('Ctrl'+'A')
Select all text in the current pane.

Copy All
Copy all text in the current pane.

View menu

Input
Toggles display of the Input pane.

Output
Toggles display of the Output pane.

Tools menu

Convert ('Ctrl'+'R')
Converts the code in the Input pane and displays the results in the Output pane.

Cancel ('Ctrl'+'Break')
Cancel the current script conversion.

Options
Displays a dialog box for configuring the VBScript Converter settings. Choose from the following options:
Number of Recent Files to Show
Specify the number of files that are displayed when File|Recent Files is selected.

Run Conversion of New Input
If this check box is selected, any new input that appears in the Input pane is automatically converted.

Show Output Window on Run
If the Output pane is hidden, it will be displayed whenever a conversion is run.

Make Backups on Save
A copy of the input is created when the file is saved.

Pane Orientation
Determines whether the Input and Output panes are displayed vertically or horizontally.

Generate Readable Code
Attempts to generate Perl code which is more readable rather than using idiomatic Perl constructs.

Emit Warnings as Comments
Show warnings about the conversion as comments in the resulting Perl code.

Help Menu

Contents ('F1')
Displays the VBScript Converter documentation.

About VBScript Converter
Displays VBScript Converter version information.