Preferences

Komodo's preferences are used to set the default behavior of Komodo. Preferences can be set for various aspects of Komodo functionality, such as editor behavior, preferred language interpreters, the Komodo workspace layout, etc.

Some preferences can also be configured on a per-file basis. For example, the configuration of line endings, indentation style and word wrap can be configured for individual files. File-specific settings override the default preferences described in this section. To configure file-specific defaults, see File Properties and Settings in the File section of the Komodo documentation.

To display the Preferences dialog box:

Filtering the Preferences List

Komodo has a lot of configurable preferences. To quickly find the one you're looking for, filter the Category list by typing in the text box above. This will start limiting the list to matching items as you type.

Appearance Preferences

Use the Appearance preferences to customize the default layout of the Komodo workspace. The functions described below can also be changed using keyboard shortcuts; see Key Bindings for more information. To customize the Komodo workspace, select Edit|Preferences|Appearance. Configure the following options:

Start Page Customization

Side Pane Layouts

This will allow you to change the appearance of the Komodo side panes. Each one of the side panes Left, Right and Bottom panes can have their own individual appearance set to one of these values:

Most Recently Used

Code Intelligence Preferences

Code Intelligence refers to the system that provides autocomplete, calltips, and the Code Browser.

Code Scanning

Controls how the Code Intelligence system scans your source code files.

Sections List

The Sections List can be sorted by:

API Catalogs

Komodo uses API catalogs to provide autocomplete and calltips for 3rd-party libraries. In the API Catalogs panel, select the libraries that you use in your code to enable them. Selecting multiple API catalogs for a particular language can yield confusing results if there are overlapping namespaces, classes or function names.

Database Explorer Preferences Komodo IDE only

Confirm Row Deletions: Toggles a confirmation dialog when deleting rows from a table.

Debugger Preferences Komodo IDE only

To customize general debugging functions, select Edit|Preferences|Debugger. For language-specific settings (such as interpreter selection), see the Language preference.

Debugging Session Startup

Debugging Session Shutdown

Debugger Editor Options

Code Profiling

When receiving a remote profiling request:

Debugger Connection Preferences

Debugger Connection Options

Advanced Debugger Preferences

The Performance Tuning settings are for fine-tuning data displayed in the Variables tabs in the debug output pane. The default values should generally be kept.

Editor Preferences

To configure editing preferences, select Edit|Preferences|Editor.

General Preferences

Options set through the Preferences dialog box are the default for all files opened in Komodo. Some display characteristics can be assigned to individual files.

Cursor Options

There are three cursor style options:

Drag & Drop

When dropping a URL in Komodo:

Confirmation Dialogs

When files that are opened in the Komodo editor are changed by another application, Komodo can be configured to respond in various ways:

If Ask me what files to reload and Ask me what files to close are selected, the prompt is displayed when:

Scrolling

The Scrolling setting determines the number of lines that are be displayed above or below the editing cursor. As the editing cursor moves, the number of lines specified here are displayed between the cursor and the top or bottom of the Editor pane. You can also set the horizontal scroll bar width by entering the desired size in pixels.

Configuring Key Bindings

Most Komodo functions can be invoked via key bindings. These key bindings can be customized. To view an HTML list of the key bindings currently in effect, select Help|List Key Bindings.

On Linux systems, key bindings defined in the window manager (including default key bindings) take precedence over Komodo key bindings. If certain keys or key combinations do not work as expected in Komodo, check the window manager's key binding scheme. In the case of conflicts, change either the Komodo key bindings or the window manager key bindings.

To configure key binding defaults, select Edit|Preferences|Editor|Key Bindings. By default, menu key bindings are accessed using 'Alt' key combinations on Windows and Linux. For example, the File menu is opened via 'Alt'+'F'. Select Remove Alt-<letter> shortcuts from menus to disable menu access via these key bindings. The 'Alt' key still activates the File menu.

Key Binding Schemes

Key binding "schemes" are sets of pre-configured key bindings. Click the links below to view a list of key bindings for each of the schemes.

Pre-configured schemes cannot be modified. When you attempt to modify a key binding, you are prompted to make a copy of the scheme with a new name before making changes.

Remove Alt-<letter> shortcuts from menus

Some Emacs key bindings use 'Alt'+'letter' combinations that are also used to access Komodo menus. To avoid this conflict, select Remove Alt-<letter> shortcuts from menus.

Vi Emulation

Vi emulation mimics the modal behavior of the Vi editor. Selecting Enable Vi emulation when a scheme other than Vi is selected prompts you to create a new scheme. This scheme is based on the current scheme with the Vi emulation behavior added.

Schemes created with Vi emulation enabled (including the default Vi scheme) will always require Vi emulation. The Enable Vi emulation checkbox cannot be toggled.

Modifying Key Bindings

To alter or view a specific key binding, scroll the Commands list or enter characters in the filter field. If multiple key bindings are assigned to a single command, the Current Key Sequence field displays as a drop-down list. Click the Clear button to delete the key binding displayed for the selected command; click Clear All to delete all key bindings for the selected command.

To add a new key binding for the selected command, enter the desired key binding in the New Key Sequence field. If the key sequence is already assigned to another command, the current assignment is displayed in the Key Sequence Already Used By field. Click Change to update the key binding displayed in the Current Key Sequence field; click Add to make the new key binding an additional key binding. If the key binding is already assigned, the original assignment is cleared.

Key Bindings for Tools

Custom key bindings can be assigned to the following types of tools:

When the key binding associated with a toolis invoked, it has the same action as double-clicking the tool in the Toolbox sidebar.

Key bindings assigned to tools in a project toolbox are only available for the active project. Key bindings for tools in the global toolbox are always available.

To assign a key binding to a tool, or to alter or delete an existing key binding, right-click the tool and select Properties, then click the Key Binding tab. Configure as described above.

Sharing Keybindings

Keybindings can be shared between Komodo installations by copying the keybinding (*.kkf) scheme files.

Configuring Indentation

From the Edit menu, select Preferences, then click Editor|Indentation.

Tab and indent widths are specified as follows:

Options set through the Preferences dialog box are the default for all files opened in Komodo. Some indentation characteristics can be assigned to individual files.

Smart Editing

Options set through the Preferences dialog box are the default for all files opened in Komodo. Some Smart Editing features can be assigned to individual files.

Configuring Word Completion

The Komodo editor maintains an index of words in the current file. Instead of re-entering words that already exist in the current file, you can use the Complete Word function to finish words. If you are using the default key binding scheme, word completion is invoked from the keyboard by pressing 'Ctrl'+'Space' ('F5' or 'Alt'+'Esc' on Mac OS X). If you also want to be able to complete words by pressing the 'Tab' key, select the check box labeled Use Tab character to complete words like Ctrl+Space. Note that the 'Tab' key can still be used for other purposes when this check box is selected. Word completion only occurs when the cursor is positioned to the right of characters in a word that has been stored in the editor's index.

Configuring Word or Character Wrap

Select an option from the Word wrap long lines drop-down list to have lines automatically "wrapped"; that is, when a line exceeds the width of the Editor pane, it wraps to the next line. This is merely a display characteristic - no end-of-line marker is inserted. You can choose Word, Character, or leave it as the default value of None. The Character option wraps the line at the immediate position where the line exceeds the width of the Editor pane; the Word option wraps the line from the beginning of the word that extends beyond the width of the Editor pane.

Note: For lines that have been wrapped automatically, the behavior of the 'Home' and 'End' keys is slightly different. Pressing 'Home' or 'End' moves the cursor to the beginning or end of the current line. Pressing the same key a second time moves the cursor to the previous or next end-of-line marker.

Select an option from the Word wrap markers drop-down list to display markers in the Editor pane. You can choose to view End of line markers, Start of line markers, Both or None. The default is None.

Configuring Edge Lines

The edge line is a vertical line that indicates a column marker.

Soft Characters

Enable soft characters turns on language-specific autocompletion for brackets, braces and other delimiters. The highlighted closing character is inserted after the cursor and can be "typed over". See Soft Characters in the Editor section for more information.

Line Cut/Copy

Cut/Copy with no selection... changes the behavior of Cut and Copy operations when there is no selection in the current buffer. By default, the current line is cut or copied if there is no selection.

Hyperlinks

Enable or disable 'Ctrl'+'mouse-hover' hyperlinks ('Cmd'+'mouse-hover' on Mac OS X) in the buffer.

Configuring Folding

Komodo can fold (i.e. hide and un-hide) logical segments of code in many languages and data file types. The following options define how code folding looks and works:

Save Options

To automatically fix whitespace errors when saving files:

When files without extensions are saved, Komodo can be configured to prompt for an action. Configure the If filename has no extension drop-down list:

Based on the specified Minutes between auto-recovery, Komodo makes temporary backup copies of all un-saved files in the editor. When the editor file is saved, then the backup copies are deleted. If Komodo is shut down abnormally (such as through a system crash), Komodo prompts to restore the backup copy when the file is next opened. If you respond "Yes" then Komodo's backup copy of the file is opened in the editor. These temporary backup files are saved into the "autosave" folder in the Komodo profile directory.

Environment

At startup, Komodo loads all environment variables it can access. If it is launched from a desktop icon rather than a shell, environment variables set in the default shell will not be loaded automatically.

To ensure that Komodo runs with the correct environment variables, (e.g. SCC settings, library locations, SSH options, etc.) set them in the User Environment Variables (override defaults) list box. Three buttons are available for manipulating this list:

Additionally, double-clicking a variable in Startup Environment Variables copies it into User Environment Variables (override defaults) where it can be edited. This new variable will override the one in Startup Environment Variables

Fast Open

The Fast Open ('Go to File') dialog can present files "gathered" from a number of sources. The following sources can be toggled:

Support is also available for go-tool, a shell command for setting and using directory aliases.

File Associations

Komodo's file associations determine the functionality of editing features such as autocomplete and code coloring. Use the File Associations preference to associate file extensions and characteristics with particular languages.

Editing the Language Associated with a File Pattern

To edit the language associated with a file pattern:

  1. Select the desired extension from the Patterns list.
  2. From the Language drop-down list, select the language to associate with the selected file pattern.

To remove an association, select the desired pattern and click Remove.

Adding a New File Association

To add a new file pattern/language association:

  1. Enter the desired pattern in the Pattern field. The pattern consists of the wildcards and the naming convention. Typically, file associations are made by the filename extension; for example, a Perl script has the extension ".pl". The pattern for a Perl script is therefore "*.pl".
  2. Select the language to associate with the pattern from the Language drop-down list.

Use File Content to Determine Language

Komodo can be configured to identify the language of a file based on its contents rather than its extension. The following characteristics can be used to override the file associations settings for syntax checking and debugging configuration.

Find

Highlighting

Incremental Search

These options set the defaults for the Incremental Search feature.

Fonts and Colors Preferences

Customizes the display of text in the Editor pane. To modify the font and color preferences, from the Edit menu, select Preferences, then click Fonts and Colors.

The Sample Text window at the top of the Fonts and Colors page offers a preview of the current scheme. If multiple schemes are configured, select the desired scheme from the Scheme drop-down list.

To create a new scheme:

  1. Select the scheme that you want to base your new scheme upon.
  2. Click the New button and enter a name for the new scheme.
  3. Make any necessary changes using the controls on the Fonts, Colors, Common Syntax Coloring, and Language-Specific Coloring tabs.
  4. Click OK to save the new scheme.

Schemes are added to the Scheme drop-down list. Remove the selected scheme by clicking the Delete button. System schemes appear in bold and cannot be deleted.

Fonts

The Fonts tab is used to configure the display characteristics for fixed-width and/or proportional fonts. Note that the default font characteristics configured on this tab are not overridden by any language-specific font configurations.

To create a scheme that affects characters in specific encodings, select the type of encoding from the Encoding drop-down list. If you do not specify the encoding, Komodo uses the system's default encoding.

The Fonts tab contains two identical sets of font controls, one for fixed-width fonts on the left and the other for proportional fonts on the right. Select the Prefer Fixed or Prefer Prop. option button to set the desired font type and then use the drop-down list immediately beneath the selected option to choose a specific font.

Colors

Use the Color Choice drop-down list on the Colors tab to configure general color properties for the Editor pane. After selecting an interface component from the list, click the box to the right of the drop-down list to choose a color from the color palette, or click the small arrow button to select a color from the system color palette.

The following interface elements can be configured:

The Override Text Color in Selection check box activates the "Selection Text Color" setting described above. The Highlight Current Line check box activates the coloring specified in the "Current Line Background Color" setting described above.

Common Syntax Coloring

Some language elements are common to a number of programming languages. The element colors specified on the Common Syntax Coloring tab applies to all languages that use these elements. Select an element from the Element Type drop-down list and use controls described below to set the font characteristics. Note that the font characteristics configured on this tab are overridden by any language-specific font configurations.

Language-Specific Coloring

The colors configured on the Language-Specific Coloring tab apply to elements that appear in a specific language. Select a language from the Language drop-down list and an element from the Element Type drop-down list, then use the controls described below to set the font characteristics.

Code Formatters Komodo IDE only

Komodo offers integrations with external code formatters. Selected text, or an entire document can be passed to the formatter, processed, returned via stdin and reinserted in the buffer.

You can configure one or more formatters for any language. Each language will have one formatter marked as Default, which is the one used by the Format Code or Text ('cmd_format') function. By default, this command does not have a key binding. You can assign one in the Key Bindings preferences.

HTTP Inspector Preferences Komodo IDE only

The HTTP Inspector runs a local proxy for examining HTTP traffic between browser and server. This proxy has the following configuration options:

HTTP Inspector Options:

Proxy forwarding:

Interactive Shell Preferences Komodo IDE only

The Interactive Shell is an implementation of the language interpreter's shell within the Komodo environment. These preferences set the default behavior for interactive shell functionality.

Internationalization Preferences

Language encodings provide support for files containing characters in non-ASCII character sets.

Encodings are determined in the following order:

  1. File Preference: If a specific encoding has been assigned to a file via the file's Properties and Settings context menu, the assigned encoding is always used when that file is opened.
  2. Auto-Detect: If the Auto-Detect File Encoding when Opened box is checked, Komodo analyzes the existing encoding of the file by first looking for a Byte Order Mark (BOM), then by checking for an XML declaration, and then by performing heuristic analysis on the file's contents. If an encoding can be determined, it is applied.
  3. Language-specific Default Encoding: Specific encodings can be assigned to programming languages. (Komodo determines the programming language of a file based on the File Association preferences.) If an encoding is associated with a programming language, that encoding is used. Check Signature (BOM) to embed a Byte Order Marker (BOM) at the beginning of the file. If the specified encoding is set to the default encoding, the System Encoding or Custom Encoding is used.
  4. System Encoding or Custom Encoding: If the Use Encoding Defined in Environment box is checked, Komodo uses the encoding specified in the operating system. The following system variables are checked:
    • Windows: The Control Panel's "Regional Settings" (Windows 98, ME, and NT); "Regional Options" (Windows 2000); "Regional and Language Options" (Windows XP).
    • Mac OS X: The "International" settings accessed via the OS X System Preferences.
    • Linux: LC_CTYPE, LANG and LANGUAGE.
    To use a different encoding, uncheck this box and select the desired encoding from the Custom Encoding drop-down list.

When you create a new file, only the third and fourth methods described above are used to set the file's encoding.

The following settings override all other encoding settings except the File Preference setting.

The Date & Time format determines the display format of the date and time for items listed on the Start Page, and for the Current File settings display.

Language Help Settings

Use the Language Help page in Komodo Preferences (Edit|Preferences|Language Help) to configure context-sensitive language look-up.

Configuring Reference Locations

The Language Lookup Commands section of the Language Help page displays the default URL for language-specific help. (The %(browser) string is an interpolation shortcut.) If you are using the default key binding scheme, 'Shift'+'F1' ('Cmd'+'/' on Mac OS X) opens a browser window and looks up the address of the sites specified here. The site is selected according to the type of file currently active in the Editor pane. (To configure file association, see File Associations.)

The General Help field is used to specify a help location that does not specifically apply to a language (or applies to a language not available in the above list).

To reset any of the help settings to their original value, click Reset beside the pertinent field.

Using Language Help

In the Editor pane, double-click to select the keyword that you want to look up. Then, if you are using the default key binding scheme, press 'Shift'+'F1' ('Cmd'+'/' on Mac OS X) to invoke a browser window and look up the keyword on the site configured in the Preferences. Press 'Ctrl'+'F1' ('Cmd'+'Ctrl'+'/' on Mac OS X) to perform the lookup using the site configured in the General Help field on the Language Help page.

Language Configuration

To configure the languages supported by Komodo, select Edit|Preferences|Languages, then select the desired language.

Configuring JavaScript

Syntax Checking: Use the checkboxes to enable or disable basic and strict warnings from the JavaScript interpreter.

JavaScript Directories: Specify any directories that you want Komodo to use for autocompletion and calltips. Komodo scans these directories recursively (up to 5 directories deep) for information.

Code intelligence for several common JavaScript libraries can be enabled in the API Catalogs section of the Code Intelligence preferences.

Configuring Node.js

  • Use this interpreter: Select Find on Path to use the first Node interpreter in the system PATH. To select a specific interpreter, select it from the drop list or click Browse and navigate the filesystem.
  • Node.js Directories: Specify any directories that you want Komodo to use for autocompletion and calltips (e.g. node_modules for a given application). Komodo scans these directories recursively (up to 5 directories deep) for code intelligence information.
  • Configuring Perl

    PDK Installation Locations

    To access the Perl Dev Kit preference page, select Edit|Preferences|Languages|Perl|PDK.

    Configuring PHP

    Komodo will try to automatically configure itself for local PHP debugging. If this fails then you'll need to manually configure PHP debugging, refer to Debugging PHP for instructions.

    Note: Be sure your php.ini configuration file is located in your operating system directory. If you used the PHP Windows installer, this file should be in the correct location. To verify, on Windows 2000/NT the php.ini file should be in \winnt; on Windows 98/Me the php.ini file should be in \windows. On Windows XP, the system directory is either \winnt or \windows, depending on whether XP was a native installation or was an upgrade from a previous Windows version.

    Sharing PHP Preferences and Files

    Use Komodo's shared support functionality to share PHP preferences, run commands, code snippets, templates, .tip files, or other items that have special usefulness within your PHP programming group. See Configuring Shared Support for more information.

    Configuring Python

    Python 2.x and 3.x are different enough that they need to be evaluated with different interpreters. The Python preference group should be set up with Python 2.x interpreters and libraries, and the Python3 group should be set up with Python 3.x interpreters and libraries.

    Komodo performs basic syntax analysis to determine which version of Python to use when a Python file is opened in the editor. This version information can be seen (and changed) in the File Type section at the right side of the status bar.

    Configuring Ruby

    Configuring Tcl

    Komodo can use the standard tclsh interpreter, the Tk-enabled wish interpreter, or any other Tcl core compatible extended shell.

    Note: Tcl Beta releases contain only version-specific executables (e.g. tclsh85.exe and wish85.exe). Komodo does not automatically find these in the path. To use them, specify them manually in the Interpreters section rather than selecting Find on Path.

    Tcl Syntax Checking

    Syntax checking support in Komodo Edit requires the TCL Syntax Checker extension.

    To specify Tcl syntax checking:

    Tcl Debugging

    Komodo's Tcl debugger has additional preferences for instrumenting files and logging debug sessions.

    Sharing Tcl Preferences and Files

    Use Komodo's shared support functionality to share Tcl preferences, run commands, code snippets, templates, .tip files, or other items that have special usefulness within your Tcl programming group. See Configuring Shared Support for more information.

    Configuring HTML

    Komodo works in conjunction with HTML Tidy to provide configurable syntax checking for HTML files. The following options can be configured:

    Configuring XML Catalogs

    Komodo has built-in support for a wide range of XML dialects. Support for additional XML dialects can be configured by adding XML Catalog files. These files map XML namespaces to local DTD and RelaxNG Schema files.

    Click the Add... button to add your own catalogs.

    Click the Delete... button to delete the currently selected catalog from the list.

    Use the arrow buttons to rearrange the order of the catalogs. Catalogs at the top of the list take precedence over those below. All catalogs specified here (and the DTDs and RelaxNG Schemas referenced by them) take precedence over the ones that ship with Komodo.

    Configuring ActionScript

    Komodo supports ActionScript syntax checking using MATC (Motion-Twin ActionScript 2 Compiler). With the compiler installed, specify it's path in the user this interpreter field.

    Mapped URIs

    Mapped URIs are associations that allow Komodo to open files specified at one location using a different path.

    For example, opening a file with the URL:

    http://www.example.org/index.html
    
    ... might open the file from:
    /var/www/index.html
    
    ... which would be an editable copy of the file.

    These URI mappings are particularly useful for:

    To map a URI (the address of an internet or network resource, such as a web URL) to a local directory:

    1. Click the Add... button.
    2. Enter the URI in the URI field.
    3. Enter the path in the Path field or click the Local... or Remote... buttons to browse to and select the desired directory.

    The Path can refer to remote paths that are accessed via FTP, SFTP, or SCP (e.g. scp://user@host.example.org:/home/user/) in addition to paths on the local filesystem. If the remote server is configured under Servers Preferences, Komodo will open the file without prompting for authentication.

    Double-click an existing mapping in the list to edit the URI or Local Path. URI mappings are substring matches. For example, /home/user/public_html/project would match any directories starting with that string (i.e. subdirectories project_1, project_2, etc.).

    New Files Preferences

    When the New button is used to create a new file, Komodo, by default, opens a text file in the Editor pane. To alter the default, select the desired file type from the drop-down list. To specify the end-of-line marker for new files, select the desired marker from the drop-down list.

    The Komodo templates used to create new files (File|New|New File) support the same Interpolation Shortcut codes as snippets and run commands. Prior to Komodo Version 2.5, only a limited set of variables could be used (for example, to embed the current date and time in files created from custom templates). The new Interpolation Shortcuts are more powerful but are backward-incompatible.

    Enter a number in the Number of recent templates to remember field to specify how many recent template names appear on the File|New drop-down menu.

    The encoding for new files is determined by the configuration of the Internationalization preference.

    Printing Preferences

    Projects and Workspace Preferences

    Workspace

    Use the When starting Komodo field to specify the display when Komodo is opened.

    Opening and Closing Projects

    These options specify the relationship between projects and files that are open in the Editor pane.

    When opening a project, set Komodo to:

    When closing a project, set Komodo to:

    File Status Updates in Places sidebar

    The Update file status automatically option enables a periodic check of the read/write status and the source code control status of files in the Places sidebar.

    Status refresh can also be performed manually with the Refresh context menu item for any tool, file or folder.

    Triggering Macros

    Macros can be configured to execute when specific Komodo events occur (such as before a file is saved or after a file is closed). To disable this feature, uncheck Enable triggering of macros on Komodo events.

    Servers Preferences

    Use the Servers page to configure server account settings for remote file access. To access the Servers page, select Edit|Preferences|Servers. You can also manually specify a connection (server name, username and password) when opening or saving remote files.

    See Opening Remote Files for information about working with remote files.

    If no servers have been previously configured, enter access information as described below and click the Add button. If there are prior server configurations, click the New Server button to clear the fields. To alter an existing configuration, select the configuration from the drop-down list, make the desired changes, then click the Update button. To delete a configuration, select the desired configuration and click the Delete button.

    Note: Passwords are stored (encrypted) using Mozilla's password manager.

    Shared Support Preferences

    Komodo's shared support functionality is used to configure components on one machine and distribute them for use on other machines. Shared support is implemented via a "Common Data Directory", which stores the shared components. The following components can be shared:

    To configure shared support, select Edit|Preferences|Shared Support.

    To access shared components, Komodo users must have "read" access rights to shared files in both the Common Data Directory and the Shared Toolbox (if the directory is not the same as the Common Data Directory). To alter shared components, users must also have "write" rights.

    By default, the The Common Data Directory is the same as the user data directory.

    To specify a custom location for the Common Data Directory:

    1. On the Edit menu, select Preferences|Shared Support.
    2. Click Use custom Common Data Directory location.
    3. Click Choose to select a new location.
    4. Click OK.

    Sharing .tip, .pcx and .pdx Files

    Through Shared Support, .tip files (which provide syntax checking for PHP and Tcl) can be made available site-wide. All .tip files should be stored along with the default .tip information in the tcl subdirectory of the Common Data Directory.

    The other file types that can be shared are .pcx files, which can be used to extend the command information supported by the TDK Checker and Komodo Tcl linter, and .pdx files, which are debugger extension files that define debugging functions, such as spawnpoints. Like .tip files, .pcx and .pdx files are stored in the tcl subdirectory of the Common Data Directory.

    Sharing Preferences

    Shared preferences are used to set a default preference configuration that is shared between multiple Komodo users. An organization or user group can specify defaults like the language type for new files, default tab widths, and other Komodo settings.

    There are three levels of preference recognition in Komodo:

    1. user preferences
    2. shared preferences (common)
    3. default preferences (factory)

    In a shared configuration, user preferences always override the shared preferences. Shared preferences always override the default preferences.

    To configure shared preferences, set the desired preferences in one instance of Komodo. (This sets user preferences for that Komodo installation.) Then, edit the prefs.xml file that stores the preferences.

    The default locations are as follows:

    Make a backup copy of prefs.xml before editing it. In prefs.xml, make the following changes:

    Copy prefs.xml to the Common Data Directory. When other Komodo sessions (configured to use the same Common Data Directory) are started, the preferences in the Common Data Directory are used.

    Because user preferences override both default and shared preferences, ensure that user preferences are not configured for items defined in the shared preferences. For example, if the shared preference contains a tab size definition and a user's personal preference contains a tab size definition, the user's preference is used, not the shared preference.

    Source Code Control Preferences Komodo IDE only

    Komodo IDE features source code control (SCC) integration, which you can use to perform the most common SCC repository tasks from within Komodo, including checking files out, comparing them to the repository version, and checking files back in. See Source Code Control for information about using SCC functions within Komodo.

    CVS Integration

    Configure these options to use CVS source code control integration.

    Perforce Integration

    Configure these options to use Perforce source code control integration.

    Subversion Integration

    Configure these options to use Subversion source code control integration.

    Stackato

    Set the path to the stackato command line client here, if it is not already in the system $PATH.

    Syntax Checking

    Background syntax checking validates code against the language interpreter as you type. (If Code Intelligence is enabled for Python, the code intelligence database is used to validate Python code.) Syntax errors and warnings are underlined in the Editor pane. See Background Syntax Checking for more information.

    By default, Komodo performs a background syntax check one second (1000 msecs) after you stop typing. In very large files, this background process can slow down editing. If you notice slowness in the editor pane, try extending the delay or disabling background syntax checking. Syntax checking can be run manually by clicking the syntax checking icon ( or ) in the status bar.

    Enable checking of mixed end-of-line (EOL) characters" checks for inconsistent end-of-line characters caused by editing a file on multiple platforms (e.g. CR-LF on Windows vs. LF on Linux).

    Language-specific syntac checking properties

    Syntax checking options for various languages can be set by choosing the language from the drop-down list, setting the desired parameters. Each language will have different options.

    Test Plan Preferences

    Settings for global test plans (see Unit Testing). Project-level test plans should be configured in the Project Properties.

    Web and Browser Preferences

    Windows Integration Preferences

    Windows Integration preferences set system-wide file associations on the Windows platform. By configuring file associations, Komodo becomes the default editor for specific file types. When one of these files is invoked (for example, by double-clicking the filename in Windows Explorer), Komodo is automatically launched (if not already running) and the file is loaded in the Editor pane.

    When a file extension is added to the "Edit with Komodo" association, the context menu displayed when the filename is right-clicked in Window Explorer contains an "Edit with Komodo" option.

    To configure file associations:

    1. Select Edit|Preferences|Windows Integration.
    2. Click Configure common associations. The Setup Common Komodo File Associations dialog box opens.
    3. Select the file extensions for which Komodo should be the default editor and the files extensions that should have the "Edit with Komodo" context menu option.

    Individual file extensions may be added and deleted via the lists.

    If another application overrides the associations configured by Komodo, click Re-apply settings to system to reset the Komodo associations.